Author Archives: Kaif o'Lom

L2TP и IPTV Mikrotik для Зеленой точки

Вспомнил, что местные товарищи из «Зеленой точки» давно просят показать им пример настройки Микротика. Пока что это заготовка, пишу по памяти пока что, потом проведем натурные испытания и поправлю, если не взлетит. Предполагается, что микротик с дефолтной заводской конфигурацией. Проще всего такие простые настройки делать через winbox, но просили по-взрослому, командную строку.
Что нужно для начала:

  • Сам роутер Mikrotik с более-менее свежей прошивкой (6.3х и свежее)
  • Адрес шлюза провайдерской сети, который выдается при подключении шнурка с инетом по DHCP (можно вычислить и самому, но проверить, уточнив у админа или подключившись компом напрямую)
  • Комп с программой winbox.

L2TP
Прописываем маршруты до серверов авторизации (xxx.xxx.xxx.xxx — адрес шлюза)


[admin@MikroTik] > ip route
[admin@MikroTik] /ip route> add dst-address=194.28.72.6 gateway=xxx.xxx.xxx.xxx
[admin@MikroTik] /ip route> add dst-address=194.28.72.9 gateway=xxx.xxx.xxx.xxx

Создаем L2TP соединение (XXXX — логин, YYYY — пароль).

[admin@MikroTik] /ip route>
[admin@MikroTik] /ip route> /interface
[admin@MikroTik] /interface> l2tp-client add connect-to=194.28.72.6 user=XXXX password=YYYY disabled=no add-default-route=yes

Включаем маскарадинг на этом соединении и добавляем правила фильтра:

[admin@MikroTik] /interface> /ip firewall
[admin@MikroTik] /ip firewall> nat add chain=srcnat action=masquerade out-interface=l2tp-out1
[admin@MikroTik] /ip firewall> filter add action=drop in-interface=l2tp-out1 chain=input place-before=3
[admin@MikroTik] /ip firewall> filter add action=drop in-interface=l2tp-out1 chain=forward place-before=7 connection-nat-state=!dstnat connection-state=new

Если все хорошо, то L2TP уже будет работать:) Дальше надо запаролить WiFi открытый по умолчанию и установить пароль пользователя.

IPTV и Multicast
Обновляем прошивку (в Winbox — System -> Packages -> Check For Updates -> Download & Install). Качаем с https://mikrotik.com/download Extra Packages под архитектуру вашего роутера, из скачанного архива добываем файл multicast-что-тотам.npk и закидываем его в микротик через меню Files winbox-а. Перезагружаем роутер.

Настраиваем интерфейсы:

[admin@MikroTik] > /routing igmp-proxy interface
[admin@MikroTik] /routing igmp-proxy interface> add alternative-subnets=0.0.0.0/0 interface=l2tp-out1 upstream=yes
[admin@MikroTik] /routing igmp-proxy interface> add interface=bridge

Прописываем фильтры:

[admin@MikroTik] /routing igmp-proxy interface> /ip firewall filter
[admin@MikroTik] /ip firewall filter> add chain=input in-interface=l2tp-out1 protocol=igmp action=accept place-before=3
[admin@MikroTik] /ip firewall filter> add chain=input protocol=udp dst-port=1234 action=accept place-before=4
[admin@MikroTik] /ip firewall filter> add chain=forward protocol=udp dst-port=1234 action=accept place-before=5

Все, дальше по инструкции для насторйки IPTV-приставки. Если она подключена по WiFi, то неплохо бы включить на беспроводном интерфейсе multicast-helper и WMM.

Ссылка на pastebin со всеми строчками, встреченными тут:)

ДСА2017

Леди и, не побоюсь этого слова, джентельмены, с праздником нас!
Мудрое решение отмечать день сисадмина в пятницу позволяет нам качественно отпраздновать эту знаменательную дату 🙂

Крепкого коннекта, быстрого пинга!

37

Вчера добавилось еще одно колечко на месте распила 🙂
Впереди громадье дел и планов, такое ощущение, что жизнь только начинается.
Отпраздновал ударно, на следующей неделе будет еще и продолжение.
Спасибо всем за пожелания и поздравления!

Один год — полет нормальный

Краткий отчет по итогам годового использования глаз после операции:)
11 марта исполнился год, как сделал операцию по коррекции зрения. Все штатно, несмотря на нифига не строгое соблюдение послеоперационных предписаний по ограничению нагрузок. Единственный обнаруженный баг — иногда, если очень сильно устал (ну или много выпил 😉 ), левый глаз фокусируется чуть медленней правого, после принудительной команды от центрального процессора. Но со временем и эта проблема практически исчезла. С врачом по поводу этого бага консультировался, получил программу тренировок по фокусировке глаз, на которую благополучно забил через пару недель. Периодически вспоминаю, но никак не выкрою времени на тренировки.
А в остальном все хорошо и прекрасно. Никак не нарадуюсь 🙂

Пробуждаемся и машем:)

С первым днем весны туман в голове рассеялся и наконец-то у меня снова появился интерес к жизни.
Видимо, в прошлой жизни был медведем, уже которую зиму приходится пинками заставлять себя делать хоть что-то превышающее минимальные потребности выживания 🙂 Ну, или же холод так действует.
Надеюсь, эффект весны сохранится, надоело быть овощем 🙂

P.S. Конечно же, всех с днем котиков.
Вот вам КДПВ (кошечка для привлечения внимания):
Концентрированое зло

Итоги 2016

Запоздалые итоги года. В декабре, под прессом кучи предновогодних дел, казалось что и вспомнить-то о 2016 нечего. Однако, на выходных до меня дошло, что я очень сильно неправ 🙂

Во-первых, я снова стал зрячим — сделал коррекцию зрения в марте и с тех пор не устаю радоваться и удивляться открывшимся возможностям. Компенсировал это антидостижением — опять набрал лишнего веса, буду бороться. Как показывает опыт — ничего сложного, только запас терпения и силы воли нужен.

Во-вторых, купил машину и получил права (да, именно в этой последовательности и с разрывом почти в полгода между этапами). Чтобы получить права, кроме исправленеия зрения, моей лени нужен был еще один стимул — пришлось поехать и купить машину 🙂 Квест по поиску машины и последующей ее жизни описывается в блоге на драйве. По идее, можно бы настроить кросс-пост и сюда, но пока что лень.

Коррекция зрения подстегнула результаты в стрельбе. Когда четко видишь мишень стрелять намного проще 🙂 Закончить курс ProShooter в «Объекте» в 2016 не успел, но только из-за отмены части запланированных поездок в Москву. Осталось два практических зачета и теоретический экзамен. Если не буду тупить, можно уложиться в пару тренировок. Из того, что пощупал за год — самые мимими это SigSauer P226 и SW M&P. С глоками общего языка так и не нашел, но, уверен, смог бы приноровиться при желании. Кстати, тренировки с пневматикой заметно помогают. Разрешением на гладкоствол и ОООП не занимался, т.к. не было свободных финансовых ресурсов на их покупку.

В работе особых изменений не было — идеи появлялись, но часто не хватало времени и средств на реализацию, а клонироваться с сохранением опыта и раздвоением сознания пока нельзя:)

Книг в этом году прочитал много, но в памяти отложились только «Ар-Деко» Круза и «Линейный крейсер «Михаил Фрунзе» Коваленко. Кучу фанфиков и старой фантастики набрал в магазине Круза, читаю потихоньку. Разочарование года — «Роза и Червь» Ибатуллина.
Из фильмов запомнился разве что «Дэдпул». Неплохо зашел «Изгой один», благодаря Вейдеру и смерти всех пложительных героев:) Проблемы идеологии «Звездных войн» заметны все больше, расползающиеся дыры их вселенной хоть и стараются латать, но все время фигня какая-то получается.

Сериалы — вспомнить нечего. Самый отстой и разочарование- «Mr.Robot». Первые три серии еще более-менее интересны, а дальше опять пошли сопли и бред.

Игры — отлично зашел близзардовский «Овервотч». Но уже потихоньку выползает проблема всех подобных игр Близзарда — сложно играть ради фана, приходится играть ради победы, откатывая одни и те же сценарии с одними и теми же героями. Поэтому абсолютное первое место в моем рейтинге этого уйдет милой киберпанковской визуальной новелле «VA-11 Hall-A: Cyberpunk Bartender Action» 🙂 Чистая и незамутненная радость с прекрасным саундтреком, всячески рекомендую.

Уф, все. С наступившим Новым годом!

Читать спецификации

Давно не писал тут, все творческие потуги шли на drive2 🙂 Видимо, пора очередной раз собираться сюда возвращаться 🙂

Сегодня в очередной раз убедился в пользе чтения спецификаций и информации о различие версий и платформ. Дома уже пару лет центром сети является Mikrotik RB2011. В сети тот еще зоопарк из кучи железа, виртуалок и даже подключенных соседей. Естественно, согласно поговорке о сапожнике без сапог, за это время в его конфиге скопилась куча костылей, хвостов от опытов и прочей давно забытой фигни. Все думал «вот будет время свободное, все красиво организую, подпишу, закомментирую, заведу в систему оповещений». Вот только свободное время уходило на какие-нибудь более приятные действия. 🙂
Недавно увидел у поставщиков новую версию маршрутизатора — RB3011. Не то чтобы мне не хватало производительности или каких-либо фич в текущей версии, но тут же появилась мега-идея «А вот куплю его, поменяю и в процессе переноса наконец-то будет повод сделать все правильно!». По диагонали быстро глянул что там нового и заказал. Причем партия была маленькой, пришлось применить ум и хитрость, чтобы урвать одну штучку из резерва 🙂
Роутер приехал и три недели ждал, когда же дойдут руки до него:)
Дошли. И тут же обнаружил, что умудрился не заметить очень важную вещь — 3011 сделан на платформе ARM, для которой у Mikrotik пока нет возможности поднять на роутере виртуальную машину, на которую много в планах по обустройству сети завязано.
Судя по всему, теперь в сети будут жить обе железки, каждая со своей функцией. Желание-то все переделать уже разгорелось, нельзя забивать, а то еще пару лет с бардаком проживу 🙂

ДСА2016

Коллеги, с профессиональным праздником нас!

Крепкого коннекта, быстрого пинга, вкусного пива 🙂

36

Позавчера второй раз исполнилось 18 🙂
С утра ничего по этому поводу написать не успел, а вечером, после бурного застолья, уже не смог 🙂
Во-первых, друзья, огромное всем спасибо за поздравления!
Во-вторых, год мне понравился: наконец-то начал побеждать в борьбе с ленью, многое успел сделать, еще больше запланировал. Так что есть куда расти и стремиться.

До новых встреч в эфире 🙂

КВН-2016

Досмотрел сегодня фестиваль КВН. Судя по нему, в этом году на просмотр Высшей лиги КВН время можно не тратить. И дело не в том, что в вышку пропустили убогие команды, а в том, что интересных команд с потенциалом просто не было. Последние два сезона и так были мало пригодны для просмотра, один ДАЛС радовал, которых в прошлом году засудили на ровном месте. Я уж молчу про команды хотя бы уровня Сочи начала 2000х. А финала, равного БГУ-Питер-Новые Армяне 1999 года, видимо, ждать уже не стоит.
Печалька 🙁