Архивы: work

L2TP и IPTV Mikrotik для Зеленой точки

Вспомнил, что местные товарищи из «Зеленой точки» давно просят показать им пример настройки Микротика. Пока что это заготовка, пишу по памяти пока что, потом проведем натурные испытания и поправлю, если не взлетит. Предполагается, что микротик с дефолтной заводской конфигурацией. Проще всего такие простые настройки делать через winbox, но просили по-взрослому, командную строку.
Что нужно для начала:

  • Сам роутер Mikrotik с более-менее свежей прошивкой (6.3х и свежее)
  • Адрес шлюза провайдерской сети, который выдается при подключении шнурка с инетом по DHCP (можно вычислить и самому, но проверить, уточнив у админа или подключившись компом напрямую)
  • Комп с программой winbox.

L2TP
Прописываем маршруты до серверов авторизации (xxx.xxx.xxx.xxx — адрес шлюза)


[admin@MikroTik] > ip route
[admin@MikroTik] /ip route> add dst-address=194.28.72.6 gateway=xxx.xxx.xxx.xxx
[admin@MikroTik] /ip route> add dst-address=194.28.72.9 gateway=xxx.xxx.xxx.xxx

Создаем L2TP соединение (XXXX — логин, YYYY — пароль).

[admin@MikroTik] /ip route>
[admin@MikroTik] /ip route> /interface
[admin@MikroTik] /interface> l2tp-client add connect-to=194.28.72.6 user=XXXX password=YYYY disabled=no add-default-route=yes

Включаем маскарадинг на этом соединении и добавляем правила фильтра:

[admin@MikroTik] /interface> /ip firewall
[admin@MikroTik] /ip firewall> nat add chain=srcnat action=masquerade out-interface=l2tp-out1
[admin@MikroTik] /ip firewall> filter add action=drop in-interface=l2tp-out1 chain=input place-before=3
[admin@MikroTik] /ip firewall> filter add action=drop in-interface=l2tp-out1 chain=forward place-before=7 connection-nat-state=!dstnat connection-state=new

Если все хорошо, то L2TP уже будет работать:) Дальше надо запаролить WiFi открытый по умолчанию и установить пароль пользователя.

IPTV и Multicast
Обновляем прошивку (в Winbox — System -> Packages -> Check For Updates -> Download & Install). Качаем с https://mikrotik.com/download Extra Packages под архитектуру вашего роутера, из скачанного архива добываем файл multicast-что-тотам.npk и закидываем его в микротик через меню Files winbox-а. Перезагружаем роутер.

Настраиваем интерфейсы:

[admin@MikroTik] > /routing igmp-proxy interface
[admin@MikroTik] /routing igmp-proxy interface> add alternative-subnets=0.0.0.0/0 interface=l2tp-out1 upstream=yes
[admin@MikroTik] /routing igmp-proxy interface> add interface=bridge

Прописываем фильтры:

[admin@MikroTik] /routing igmp-proxy interface> /ip firewall filter
[admin@MikroTik] /ip firewall filter> add chain=input in-interface=l2tp-out1 protocol=igmp action=accept place-before=3
[admin@MikroTik] /ip firewall filter> add chain=input protocol=udp dst-port=1234 action=accept place-before=4
[admin@MikroTik] /ip firewall filter> add chain=forward protocol=udp dst-port=1234 action=accept place-before=5

Все, дальше по инструкции для насторйки IPTV-приставки. Если она подключена по WiFi, то неплохо бы включить на беспроводном интерфейсе multicast-helper и WMM.

Ссылка на pastebin со всеми строчками, встреченными тут:)

ДСА2017

Леди и, не побоюсь этого слова, джентельмены, с праздником нас!
Мудрое решение отмечать день сисадмина в пятницу позволяет нам качественно отпраздновать эту знаменательную дату 🙂

Крепкого коннекта, быстрого пинга!

ДСА2016

Коллеги, с профессиональным праздником нас!

Крепкого коннекта, быстрого пинга, вкусного пива 🙂

ДСА2015

Коллеги, с профессиональным праздником нас!
Крепкого коннекта, быстрого пинга и все такое:)

Удивительно, но последнее время снова потянуло писать в блог. Решил, что день сисадмина — хороший повод для начала. Stay tuned.

ДСА

С праздником, коллеги!
http://sysadminday.ru/

Новый хостинг и все-все-все

Перетащил блог на собственный хостинг. Как обычно, движителем прогресса явилась лень:) У R01, где раньше хостился, сменилась хостинг-платформа. Новая система довольно убога, а за старый добрый Plesk хотят дополнительных денег. Так что разбираться, почему блог, проработавший на новой платформе почти год неожиданно помер было откровенно лениво, показалось намного проще устроить свой хостинг. (Естественно, с блэкджеком и шлюхами ;))
Тут я мог бы сказать много «добрых» слов про линуксоидное ПО, две идентичные инсталляции которого почему-то не приводят к одному и тому же результату, но не буду провоцировать холивар. В итоге-то все заработало 🙂 Где-то внутри даже проснулся гарфоман, постоянно генерирующий темы для новых сообщений, так что если он победит лень, но новые посты тут будут появляться чаще:)

P.S. Из-за новых драконовских правил на приложений в Фейсбуке пришлось отказаться от кросспостинга туда. Намного проще врукопашную закинуть ссылку, чем выполнять все требования.
P.P.S. Широко известный в узких кругах (с) chat.kbsu.ru тоже хостится у нас, кстати. В отдельной виртуалке, как федеральная республика 😉 Вскоре переедет по новому адресу http://chat-kbsu.ru/ из-за отказа универа предоставлять доменное имя в будущем (какое-то время будет работать редирект).

Олимпийский выходной

Устроил себе и сотрупникам сегодня выходной в честь олимпиады. У нас полгорода перекрыли для движения транспорта, чтобы поносить по стадиону факел кругами. В официальном объявлении это было преподнесено как «ограничено движение транспорта по периметру стадиона» 🙂
Представляя, какие будут сегодня пробки, раскидали дела на другие дни и отдыхали дома. Еще и снег посыпал густо, добавил приключений автолюбителям.
В очередной раз понял, что не умею отдыхать — к обеду, когда отоспался стало скучно и захотелось на работу:) Пришлось срочно искать себе дома приключения.

NY 2014

С Новым Годом, друзья-товарищи! Плодитесь и размножайтесь, будьте счастливы и делайте счастливыми других:)

Понимаю, что, кроме меня самого, нафик никому это не надо, но, по сложившейся традиции, напишу:)

Удалось сделать чуть больше половины запланированного. Много мелких побед, но мало стратегических успехов. Основной противник — лень, как и всегда:)
Большая часть воспоминаний связана с работой — ее было много, в связи с прошлогодней сменой должности. Успешно боролся со своей асоциальностью и мизантропией. Научился твердо говорить «нет», что помогло обрубить хвосты в двух убыточных проектах. Причем, в одном случае все удачно разрешил в нашу пользу с продолжением сотрудничества в другом статусе.
Под конец года захватил местный рынок серверов видеонаблюдения:)
Сдал сертификационные экзамены Microsoft. В следующем году добьем необходимый уровень продаж и апнем статус фирмы.

Много катался, часто совмещая работу/учебу с развлечениями. Больше всего от моих набегов пострадал Краснодар, а по музею 30-летия победы смогу водить экскурсии, при необходимости:) Надо, кстати, написать зловредный пост про него, про качество подачи материала и неправильные информационные таблички.

Впервые за кучу лет съездил в полноценный отпуск, в Болгарию. Впервые выбрался за границу, однако. Подтвердилась прошлогодняя теория, что могу плавать не только пьяным, но и трезвым:)

Плотно занялся своей физической формой. Спорт затягивает, особенно когда начинаешь видеть результат.

До встречи в будущем году:)

Бизнес по-местному

Иногда, когда на фирме или у меня лично образуется лишнее железо, которое нежелательно или неудобно реализовать через организацию, вывешиваю на местном форуме объявление о продаже.

Заметил тенденцию: если выставляю на продажу хорошую железку с приятной ценой — ноль отзывов. Ну, или в лучшем случае ответы в стиле «я б купил, да денег нет». Как мне сказали инсайдеры — со мной не хотят спорить о цене, так как боятся, что могу слишком грамотно ответить, вежливо послать и обосновать далекий посыл:)

Но стоит выставить какую-нибудь гадость с прямым указанием, что не хочу продавать через фирму  это унылое гавно, за которое мне стыдно отвечать своей репутацией — так за 3 часа получаю минимум 5 предложений о покупке.

Я, в принципе, при хорошем стимуле и уверенности в своей правоте, могу продать эскимосам снег на севере, но этот феномен понять не могу.

SysAdmin day 2013

Коллеги, с праздником!
Крепкого коннекта, быстрого пинга, вкусного пива. Не забывайте расти профессионально, наша учеба никогда не заканчивается;)